Requirements For Stocker

Software Requirements and Hardware Guidlines

Stocker WMS, itself, has minimal hardware and software requirements. Any prerequisites are imposed by the Database Manager selected. Currently Stocker WMS only supports Microsoft SQL Server.

Stocker will operate on any modern standard PC running Windows. Indeed it may have the lowest hardware and software requirement specification when compared to other Warehouse Management Systems offering similar functionality. The design of Stocker has focused explicitly on performance to target delivery on very low specification PC's.

To this end Stocker has been tested on older Pentium II's (as a client to SQL Server hosted elsewhere) through to dual-core and quad-core machines.

Below is a list of the small requirements for installing Stocker WMS.

Supported Operating Systems

  • Windows 7 x32/x64
  • Windows 8 x32/x64
  • Windows 10 x32/x64
  • Windows Server 2008 and later

Database Manager

  • Microsoft SQL Server. The following versions are supported:
  • SQL Server 2008 - must be pre-installed.
  • SQL Server 2012 - must be pre-installed.
  • SQL Server 2014 - either pre-installed or optionally installed with Stocker.
  • SQL Server 2016 - must be pre-installed.

SQL Server 2014 is the default database for Stocker. If you do not currently have SQL Server you have the option to install SQL Server 2014 Express edition.

Note. If you install SQL Server yourself you must configure it to use SQL Server Authentication.

Other Database Managers

SQL Server is the only actively supported database. However, Stocker has been designed and interfaces have been written for the following databases.

  • Oracle
  • IBM DB2
  • Pervasive PSQL

During the development of Stocker 5 communication and general access to databases using these DBMS was tested. Although Stocker's interfaces have been, and continue to be, maintained there are no installations at present.

Hardware and Software Requirements for SQL Server 2014

Please refer to the Microsoft guide by following the link:

SQL Server 2014 Prerequisites

Hardware and software Requirements for Stocker

There are no special hardware or software requirements, most modern PC's would suffice. However, for usability, it is recommended to have a monitor with a resolution at least 1152x864.

General Guidelines

The requirements listed above outline the basic hardware and software requirements for Stocker to operate. However, PulseStar would also like to point out a few additional recommendations.

  • If you are installing SQL Server Express, install SQL Server and the Stocker database on a dedicated computer - the server.
  • If you have a single user system you can use Stocker on this dedicated machine.
  • Do not install SQL Server and the Stocker database on a machine accessed by numerous people.
  • To avoid compromising the server with virus infections do not use a machine which has general access to the internet.
  • Before installing on a pre-used and dedicated machine, it is recommended to thoroughly clean the computer of all unwanted data and defragment the disk.
  • It is always recommended regard Microsoft recommendations as the bare minimum for your server.